You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2018-01-30 15:37:28

nyk12admin
Member
Registered: 2018-01-30

environment goes to sleep during long workflow?

We've been having issues with the deploystudio runtime going to sleep in the middle of a workflow--and it's not just the display. I will start an image, go to lunch, come back and touch the keyboard only to have it suddenly continue with a workflow step that should've been completed awhile ago.

We're using build v1.7.8 running on 10.11.6, but the netboot image was created on High Sierra.

I don't know if the netboot picks up its power settings from the machine that created the netboot image or not, but we never had that issue before. I may try to recreate the netboot image after setting the source machine to never sleep.

Any thoughts, similar experiences?

Offline

#2 2018-01-31 18:12:11

sseaton1971
Member
Registered: 2012-05-15

Re: environment goes to sleep during long workflow?

I always run a script when the runtime loads to prevent the netbooted computer from going to sleep. Just make it the first step of the workflow.

Offline

#3 2018-02-13 15:53:31

nyk12admin
Member
Registered: 2018-01-30

Re: environment goes to sleep during long workflow?

We found a better workaround for this. We execute this command before doing anything else:

pmset sleep 0

Offline

#4 2018-02-13 15:58:43

nyk12admin
Member
Registered: 2018-01-30

Re: environment goes to sleep during long workflow?

A colleague just informed me that we also are doing pmset disksleep 0 because apparently the disk goes to sleep during his workflow for some reason.

Offline

#5 2018-06-06 11:29:22

andrei.labin
Member
From: Zuerich
Registered: 2008-03-17

Re: environment goes to sleep during long workflow?

I've tried running a script with
pmset sleep 0

but that didn't help. This is a real bummer as we need to deploy 10.13 to our labs and need a 10.13-nbi for apfs-support.

I'll try also including:
pmset standby 0
pmset displaysleep 0

Currently running on DS 1.7.8 with a 10.13.4-nbi (with the replaced afps-framework) to thin-image macpros with a lot of large packages.

Offline

#6 2018-06-28 19:26:14

chrisb42
Member
Registered: 2014-03-14

Re: environment goes to sleep during long workflow?

So are you just running a small script at the beginning of the workflow with those pmset commands? I'm going to try that tomorrow, because my 10.13.3 nbi, which worked fine to create and deploy images on a small scale, had issues when applied to one of our daily lab reset workflows with a high double-digit number of iMacs, with machines just stopping somewhere in middle of the workflow, and that's not something I have seen with my 10.12.6-based nbi.


The results of my little experiment described above are not good. Just having a small script with the "pmset" commands did not work, a lot of the machines still got stuck in the middle of the workflow. :(

Any ideas?

Last edited by chrisb42 (2018-07-10 00:08:35)

Offline

#7 2018-07-16 13:17:54

gwertman
Member
Registered: 2012-10-04

Re: environment goes to sleep during long workflow?

This happened in my environment as well using a newly created nbi from a 2017 iMac running 10.13.5 with default power settings. I had to go back to an nbi using 10.12.6 as I didn't have time to troubleshoot. I'd love to know what this is happening though.

Offline

#8 2018-07-24 17:48:07

chrisb42
Member
Registered: 2014-03-14

Re: environment goes to sleep during long workflow?

Seriously, if anyone has successfully prevented machines from going to sleep when using a High Sierra-based nbi (needed for proper APFS support), please share the details here. I would really love to know how I can reliably deploy APFS-based images, and at this point I cannot due to this issue.

-Christian

Offline

#9 2018-08-16 03:35:11

chrisb42
Member
Registered: 2014-03-14

Re: environment goes to sleep during long workflow?

For the benefit of everyone who has the same problem and finds their way here, Peteo shared his command he uses and it works for me as well:

/usr/bin/pmset sleep 0 disksleep 0 networkoversleep 1 acwake 1 displaysleep 0 gpuswitch 0

That should get your workflows continuing and finishing as before with HFS.

-Christian

Offline

Board footer

Powered by FluxBB