You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2013-02-26 11:53:54

jelockwood
Member
Registered: 2009-11-11

Error installer (not) updating NetBoot files

My current successfully running DeployStudio setup is 1.0rc135 (b121112). I am trying to update it to either 1.5.16 or 1.5.17, either installer gives the same error which is that it cannot update the NetBoot image and refers me to the install.log for more details.

The design of DeployStudio is supposed to allow updating the runtime on the NetBoot image, however when I look through the install.log I find the following messages -

Feb 26 10:44:33 lon04-macmgmt-01 installd[55599]: ./postflight:   updating DeployStudio components in netboot set /Volumes/Macintosh HD/Library/NetBoot/NetBootSP0/DeployStudio-ML.nbi
Feb 26 10:44:33 lon04-macmgmt-01 installd[55599]: ./postflight:   ...update aborted, incompatible NetBoot set version (1.48 != 1.49)!

This seems to suggest that because the NetBoot was produced with an older version (1.0rc135) the new version cannot update it. Now as 1.5.15 is clearly a big change in version number compared to the previous 1.0rc135 I could understand if in this particular case updating it possible but I have not seen any notice in the change history or elsewhere that this should be the case. If this is the case it would have been helpful to everyone to make this clear so as to avoid confusion.

What is everyone else's experience regarding this? If it not possible to update the NetBoot in this case?

Offline

#2 2013-02-26 16:09:25

gehrked
Member
Registered: 2012-07-05

Re: Error installer (not) updating NetBoot files

I've simply never relied on the auto-updating of NBIs and just recreated new ones after every update in order to avoid any sort of issues.

Offline

#3 2013-02-26 19:15:06

admin
Administrator
Registered: 2007-03-29
Website

Re: Error installer (not) updating NetBoot files

The upgrade occurs as long as we don't change the assistant NetBoot set builder script between two releases of deploystudio.

Offline

Board footer

Powered by FluxBB