You are not logged in.


[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-10-04 22:36:40

Registered: 2015-06-25

1.7.8 on macOS 10.13 - DS Repository Access error & logs

After a week of trying different settings I was finally able to get the NetBoot image created with 1.7.8 on 10.13 to boot.  Still takes about 6 minutes, but it boots.  Now, when DS starts the workflow selector, I am getting the ole Repository Access error.  I have tried every configuration that I can think of on both the DS Assistant for the server itself, as well as the NetBoot Image.  I have tried the full DNS name, DNS short name, DNS short name .local, static IP address...nothing works.  I can use the OS Go > Connect to Server using all of those options and can connect just fine.  Heck, I even sat with both my working El Cap DS next to my High Sierra DS and went screen by screen, making sure the setup matches (the the change to HTTP and SMB, since HS can't use NFS and AFP).  No luck.

One bit of information I was able to get was a screenshot of the logs on the target computer showing where it fails.  It seems to be failing when DS is:

Mounting repository share point...
/bin/mkdir /tmp/DSNetworkRepository 2>&1
/bin/chmod 777 /tmp/DSNetworkRepository 2>&1
/bin/chmod 777 /tmp/DSNetworkRepository 2>&1 (yes, its listed twice in the log)
Mount call...
mount_smbfs: server rejected the connection: Authentication error
Parsing result...
Mount failed cleaning local mount point...

Before it mounts the repository share point, the logs show that the user "ds" was successfully authenticated.  Logs show its connected to the server and that the server is reachable on port 445.


Last edited by Trikster (2017-10-04 22:37:07)


#2 2017-10-10 22:33:40

Registered: 2015-06-25

Re: 1.7.8 on macOS 10.13 - DS Repository Access error & logs

Any ideas folks?  I am stuck at this point and cannot think of any way around it...


#3 2017-10-11 10:27:04

From: Delft, Netherlands
Registered: 2008-09-02

Re: 1.7.8 on macOS 10.13 - DS Repository Access error & logs

Technically there are 2 user/pw combinations in place
1-the user to connect to https://dsserver.local:60443
2- the user used to connect to the repo share (defined during the server setup wizard, check in deploystudio pref pane on server)

the repo can be on the same server, using the same user/pw, but can also be on a remote server, using different set of credentials.
so the first message " user "ds" was successfully authenticated." is from step 1, and not for step 2

Can you connect to the repo share (smb or afp, use same url or IP address as listed in pref pane) using the credentials in use by DS (as visible in the pref pane)?
If yes, maybe the setup needs to be redone with the correct credentials
If no, fix repo access

Did you enable the option to use smb v1 for connections (usually not needed)?


#4 2017-10-11 19:41:18

Registered: 2015-06-25

Re: 1.7.8 on macOS 10.13 - DS Repository Access error & logs

Thank you for the response. The DS server is a dedicated box that sits on my desk. For ease of setup, the passwords are pretty simple. I can connect to the box via SMB and the same credentials without issues. I have tried with the SMB1 option checked, but I don’t remember if I did with this configuration. I will try again. I have been working on this issue for weeks, I have tried darn near everything. I wonder if the keyboard issue might have something to do with it.


#5 2018-06-19 08:30:59

From: Meppel
Registered: 2012-04-03

Re: 1.7.8 on macOS 10.13 - DS Repository Access error & logs

Hi, I'm not sure if you got this working but I did.

I have a Mac mini running on macOS 10.13.5 with Server 5.5 (upgraded from a working DS on 10.11)

Then I ran into the repository mounting issue too.

I've deleted the share from the system prefpane and then went into the server App and created a new user called 'deploy'.
Then I assigned the share (DS repo) folder as homefolder.

After that I ran DS Assistant and chose network repository en selected the share.
Now I can boot into DS runtime again...

Now I have to go and find a working solution for 10.13.5 restore, but thats another topic ;-)


Board footer

Powered by FluxBB