You are not logged in.


[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-04-19 13:57:42

Registered: 2016-02-18

DSR 1.7.6 with MacOS 10.12.4 Multicast Kills DS Server

Having a new issue after upgrading my DS Server to 10.12.4. I've updated my image no problems deploying unicast but if I use a multicast workflow, at the point where the server should start the multicast stream, DeployStudio takes a crap. Grey status in preference pane, can't restart via on off switch. If I restart the server the services starts up and runs again fine until the next attempt at multicast. If I manually start the multicast stream before I start the clients off it seems to work. Also once the multicast has failed and the above crash thing happens, I can no longer manually start a multicast using that image. I get the unsupported filetype or to many streams error. Nothing looks off in the logs. But I'll grab them next time I run the thing. Has anyone seen this or have any suggestions?

I've managed to get DSR running more consistently. It seems my image was corrupt, when I tried to manually start the multicast with when I was getting the unsupported file type error that should have been a hint.
I can get Multicast to work from time to time, It almost allways fails when the first client joins the stream, massive packet errors and failure immediately. If I choose the same workflow again, it usually will complete the multicast deployment. also if others join after that first one starts they seem to have pretty good luck finishing. I'm having the best luck using a netboot set made from a 10.11 machine.


Last edited by jwillis44 (2017-04-24 17:27:01)


#2 2017-06-07 20:04:47

From: Long Beach, CA
Registered: 2009-07-21

Re: DSR 1.7.6 with MacOS 10.12.4 Multicast Kills DS Server

I am having jwillis44's original problem, butI'm not getting the unsupported filetype error. Once the multicast fails DS server is unresponsive. The following entry repeats about every 30 seconds in system.log until I restart the server:[1] (com.deploystudio.server): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

Testing with macOS 10.12.5 and DS 1.7.6. Created a 10.12.5 NetBooter using DS Assistant on the server. Serving NetBooter over NFS (HTML didn't work either and was glacial and inconsistent in booting the client).
Can't find any other DS log besides the one in the DS directory. That one ends saying the firmware is ok and that it is Running autostarted workflow...



#3 2017-12-22 22:25:47

Registered: 2012-05-15

Re: DSR 1.7.6 with MacOS 10.12.4 Multicast Kills DS Server

I might have a solution. This is what has worked for me.

I was getting errors when clicking on an image to multicast in the DS Admin app. I tried lots of possible fixes, and nothing seemed to work. Then I decided to start multicast on the server via CL. Once a client netbooted to the DS Runtime, I launched Terminal and manually started the multicast restore. Everything worked well, so I knew that there was not a problem with how I set up server.

After a little more troubleshooting, I discovered that DS Admin creates a multicast plist file in /tmp when trying to start a multicast stream of an image. That is where DS Server becomes unresponsive and the entire macOS Server computer has to be restarted. Before I restarted, I copied the plist file to the Desktop. When I rebooted, I copied the plist file into /tmp. I then selected the image in the DeployStudio Admin app and clicked on the little multicast button. And, that was it! Multicast Restore bliss. Strangely enough, I could then start and stop the stream all I wanted via the admin app without problems until the server computer was restarted again. There must be some sort of permissions issue, but I have no idea what it is... and I don't have time to figure it out. All I know is that I have the ability to multicast restore again.

Hope this helps someone.


#4 2018-03-23 03:41:39

Registered: 2009-08-06

Re: DSR 1.7.6 with MacOS 10.12.4 Multicast Kills DS Server

Anyone find a permanent fix for this yet?  I'm in the same situation.  Server is OSX 10.12.6, DS 1.7.6.  Multicast attempt locks up server completely.


Board footer

Powered by FluxBB